Get in touch
Back
Resolved

Review option not visible in the dashboard

Started .

App
Created

We received reports that the Review tab is missing from the dashboard for some users. Please note the page remains accessible via direct link.

We have just deployed a fix, and the issue should be resolved.

Posted .