Get in touch
Back
Degraded

Web app experiencing high query times and sporadic errors

Started 31 Mar at 10:51am PDT, last updated 1 Apr at 11:25am PDT.

App
Updated

We identified the root cause. In certain scenarios, builds can upload hundreds of thousands of files. In asking for the URLs to upload to, this stresses the database beyond what it was designed for causes slowdowns and errors.

Fixes + monitoring in place.

Posted 1 Apr at 11:25am PDT.
Resolved

Database metrics have returned to normal. Investigating potential root causes to come up mitigation strategy so that it doesn't happen again. Will update y'all here.

Posted 31 Mar at 11:09am PDT.
Created

The web app is experiencing high query times and sporadic errors. Our infrastructure team is investigating.

Posted 31 Mar at 10:51am PDT.