
Builds taking longer than usual
Started 24 Jul at 02:36am PDT, resolved 24 Jul at 08:58am PDT.
Resolved
We've confirmed that build performance has returned to normal, and the earlier delays have been fully resolved.
All new builds are processing as expected. If you still have builds from earlier that appear stuck or delayed, you can allow them to complete on their own.
We’ll continue to monitor closely.
Updated
We believe we have identified the root cause of the issue and have implemented a fix. We are seeing improvements in processing times and will continue to monitor and update this page.

Re-appeared
We have received reports that the issue with build delays is still affecting some customers. We have reopened this incident and are actively investigating.
We’ll share updates here as soon as we have more information.
Resolved
We have seen sustained and improvement and believe that the root cause of the build time delays has been resolved. Users may see builds that were in progress during the incident continue to take extra time and occasionally timeout, but new builds should be processed quickly.
If you prefer, you can cancel builds to avoid waiting and rerun them now, or you can allow them to complete or timeout at the 2 hour mark.

Updated
We believe we have identified the root cause of the issue and are testing fixes. We are seeing improvements in processing times and will continue to monitor and update this page.
Updated
Our team is still working to resolve the slowdown in build progress. We will continue to update here as we make progress.

Created
We have detected an increase in build times and the number of pending builds. Our team is responding to ensure that builds in process proceed without having to be cancelled or rerun.