Get in touch
Back
Degraded

Performance degradation

Started , resolved .

App
Resolved

We've resolved our performance issues from this morning and the app experience is back to normal. If you are experiencing any further issues, please reach out to support with questions.

Posted .
Updated

We've seen some improvements in app performance due to our mitigations and we'll continue to work to restore performance to normal levels.

Posted .
Created

We've become aware of a performance degradation in the app that is causing the duration of requests to increase. We are working on diagnosing this problem and are deploying mitigations to keep the app experience good. We'll keep this page up to date as we work through this issue.

Posted .