Get in touch
Back
Degraded

Bitbucket access unavailable

Started 9 Dec at 10:40am PST, resolved 13 Dec at 12:56pm PST.

App
Resolved

We've confirmed that the issue is resolved. Tokens should refresh on their own with no user action required. If you continue to have any problems or questions about your Bitbucket projects, please reach out to support@chromatic.com or in-app chat.

Posted 13 Dec at 12:56pm PST.
Updated

Testing is continuing for the fix, no further updates at this time.

Posted 13 Dec at 12:34pm PST.
Updated

Testing is continuing for the fix, no further updates at this time.

Posted 13 Dec at 11:59am PST.
Updated

Testing is continuing for the fix, no further updates at this time.

Posted 13 Dec at 11:36am PST.
Updated

We are testing a fix for the problem right now. If tests pass and the problem is resolved, we will deploy the change and update when we confirm resolution.

Posted 13 Dec at 11:02am PST.
Re-appeared

We have identified a breaking change to the Bitbucket API that is causing recurring issues for Bitbucket projects, despite the steps we outlined yesterday for resolving the issue. We have identified what we believe is the root cause of all of these issues and we are working on a fix.

We will give updates every 30 minutes of every hour until we have a final update on this incident.

Posted 13 Dec at 10:32am PST.
Resolved

We've identified additional steps that are helping to restore user's connections to Bitbucket. If you are still unable to connect your project to Bitbucket, try the following steps:

  1. Identify the token holders on their affected projects (found on the Manage -> Configure page in the "Bitbucket Access Token" section)
  2. Identify the token holder for the account these projects are in (found on the account's Settings page)
  3. Have this person (or persons, as there can be different token holders for projects vs accounts, and different token holders in different projects) log out of Chromatic and back in. This will associate them with a valid Bitbucket access token.

If you are unable to contact a token holder to have them log out and log back in, you can replace the token with a new one for a different user. If you do this, ensure that you have logged out and logged back in to Chromatic first so that you are using fresh login tokens.

If you have additional questions or these steps are still not resolving the problem, please contact support@chromatic.com or reach out via in-app chat.

Posted 12 Dec at 01:33pm PST.
Re-appeared

We've received reports that our recommendations for resolving this issue are only working for some customers. Additionally, we've received reports of customers seeing the following error, which we can confirm is related to this issue:

INTERNAL_SERVER_ERROR: Failed to get new access token after 8 tries.

We're re-opening this incident until we can confirm the resolution of the Bitbucket issue or provide an adequate workaround. Thank you for your patience.

Posted 12 Dec at 07:38am PST.
Updated

Some customers have reported continuing issues with the Bitbucket API since the downtime over the weekend.

We are investigating on our end, but for now, unlinking the project and then relinking it appears to reestablish connection for most customers.

We will update this incident as we get more information. If you continue to have issues with your project, please reach out to support@chromatic.com by email, or using our in-app chat.

Posted 11 Dec at 09:29am PST.
Resolved

Now that Atlassian's maintenance period has come to an end, accounts with Bitbucket integrations are working normally.

Posted 9 Dec at 02:46pm PST.
Created

Retrospective Incident: Due to planned maintenance in Atlassian's Bitbucket service, accounts which integrate with Bitbucket were not behaving as expected.

Posted 9 Dec at 10:40am PST.