Get in touch
Back
Degraded

Longer build times

Started 18 Sep at 11:15am PDT, resolved 18 Sep at 11:31pm PDT.

App
Resolved

Build times have returned to normal for several hours and the AWS incident has resolved.

Posted 18 Sep at 11:31pm PDT.
Updated

We are continuing to see elevated build times across the board due to the ongoing AWS outage in us-west-2 and will continue to monitor the situation. Once AWS gives the all clear, we will confirm that build times have returned to normal.

Posted 18 Sep at 04:56pm PDT.
Updated

We are seeing signs of improvement in our infrastructure and believe the mitigations they are applying are having an effect. We'll update this status page with more information, but we are cautiously optimistic that build times should be returning to normal soon.

Posted 18 Sep at 12:57pm PDT.
Updated

We are currently being affected by an AWS Operational Issue impacting multiple regions. Please see https://health.aws.amazon.com/health/status for more information. We are continuing to work on mitigating impact to our customers and will continue to update this page.

Posted 18 Sep at 11:54am PDT.
Created

Build times for all browsers are elevated right now, with builds that utilize Edge and Safari particularly impacted. We are addressing the issue now with mitigations and will update this page shortly with more information.

Posted 18 Sep at 11:15am PDT.