Resolved
We've confirmed our mitigations have resolved the underlying incident and are increasing capacity limits to handle future events of a similar size. All clear!
Posted 9 Aug at 12:57pm PDT.
Updated
Build times are now returning to normal and we are monitoring the situation to ensure non-recurrence.
Posted 9 Aug at 12:48pm PDT.

Created
We are working to mitigate a volume congestion issue that may cause some builds to take longer to run than normal to complete. Builds are still being processed and completing but we will update this page with developments.
Posted 9 Aug at 12:31pm PDT.